Passer le menu

Auteur Sujet: Lyne Segfault sur Ubuntu 18.04  (Lu 457 fois)

Rollniak

  • Sysadmin
  • Résident du Palais
  • *
    • Voir le profil
Lyne Segfault sur Ubuntu 18.04
« le: 17 février 2022 à 01:53:09 »
Bonjour,

Lyne a rapportée avoir un souci pour lancer le client. Le chat est le médium qui m'est le plus difficile pour rester concentré donc je lance le sujet ici. :)

Le système d'exploitation est Ubuntu 18.04.
La version de Godot m'est inconnu.

Log XMPP:

Spoiler for Hiden:
Citer
YannK 22:42
J’ai une erreur à l’ouverture du projet, ça me dit que le fichier main est corrompu ou fautif. mais ça s’ouvre quand même et ça se lance ensuite…

Lyne 22:43
Moi, j'ai une erreur de segmentation quand j'essaie de lancer godot

AleaJactaEst 22:44
tu as quel commit sur la branch

git log

YannK 22:44
Moi j’ai pull les derniers

Donc à jour avec tes derniers pushs 🙂

AleaJactaEst 22:45
je viens juste de pousser un update 🙂

Lyne 22:45
Faut que je re-télécharge tout ?

(Et je ne sais pas trouver la branche dans ce que j'ai téléchargé. J'ai fait ça cet après-midi)

YannK 22:46
AH, super, je vais regarder si ça corrige alors 🙂

AleaJactaEst 22:47
hier, j'ai eu un problème dans un merge entre la branch main et ma branche (et je crains d'avoir embarqué une mauvaise manipulation de ma part)

YannK 22:47
Ah, tu as push sur ta branche. Moi je parlais de la branche main 🙂

AleaJactaEst 22:47
oui, et après je merge sur le main

bon en attendant, peux-tu refaire un test

YannK 22:47
oui, je teste ta branche 🙂

Déja, plus d’erreur au chargement du projet 🙂

AleaJactaEst 22:48
bonne nouvelle

Lyne, tu utilise quelle système ?

Lyne 22:49
Ubuntu, 20.4

Pardon. 18.04

22:49

**Lyne

n'a pas encore fait la migration

AleaJactaEst 22:49
pas de problème, bon va faloir que je 'li

l'installe quelque part

YannK 22:50
Et tout semble ok pour moi sur ta branche, AleaJactaEst 🙂

22:50

**YannK

s’est baladé un peu partout ^^

AleaJactaEst 22:54
Lyne, concernant segfault, tu doit avoir une ancienne librarie (regarde en lançant sur une console dans le répertoire du jeux : ldd Godot_v4.0-alpha2_linux.64)

mais je crains que l'on doit faire un upgrade

de ton ubuntu

Lyne 22:55
Mouais... Ou que j'attende pour vous donner du boulot :-°

AleaJactaEst 22:56
Yannk, sinon j'ai vue un mur invisible dans la nouvelle zone vers le pont coupé/bloqué

YannK 22:56
oui, c’est exprès 🙂

AleaJactaEst 22:56
ok, donc tout va bien

Lyne 22:57
Mmmh... le résultat du ldd est pas super-lisible. Mais je pense que la ligne qui nous intéresse est "libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007f35dc425000)
"

AleaJactaEst 23:07
as-tu une ligne sans un fichier associé (sans => /xxx/xxx/xxx)

[ignore linux-vdso.so.1]

Lyne 23:08
Dans le ldd ?

AleaJactaEst 23:08
oui dans le résultat de ldd

je cherche à savoir s'il manque une librarie

Lyne 23:09
Je te copie ça quelque part, ça sera plus simple

AleaJactaEst 23:09
ok

Lyne 23:11
https://pastebin.com/irKc74dd

AleaJactaEst 23:17
il te manque la librarie glibc v2

étrange

fichier : /usr/lib64/ld-linux-x86-64.so.2

ou pour toi : /usr/lib/x86_64-linux-gnu/ld-linux-x86-64.so.2

rollniak 23:21
AleaJactaEst: peut-être qu'il faut un version devel ?

J'ai pas touché a du Ubuntu Debian depuis un baille pour en être sûr 🙂

AleaJactaEst 23:22
je suis sceptique, ici il me semble plus un problème de librarie.

Lyne 23:22
En effet, je n'ai pas de "ld-linux" quelque chose and /usr/lib/x86_64-linux-gnu

*dans

rollniak 00:30
Lyne: qu'elles sont les étapes que tu a suivie pour  tester le client ?
Tu a suivie les instructions sur le dépôt Git ?

Lyne 00:30
J'ai téléchargé tout le contenu du dépôt git, et j'ai lancé le script start-client-khanat.sh (ou un truc comme ça)

J'ai eu le segfault à la fin (ligne 126)


Les pages du wiki et le dépôt utilisées pour la recherche d'information sont les suivantes:
Khaganat.net => Télécharger => Client Godot 3D => Dépôt Khanat client

Du coup j'ai quelques questions:

- Nous testons le client depuis le dépôt précédemment cité ?
- Quelle branche est utilisée pour le test ? Il est mention d'un branch main inexistante, je suis un peu perdu ^^'.
- Sur le tchat il est fait mention de l'usage d'un script, hors le seul script présent dans les dépôts est local/local.sh.
- Quel est donc ce script ?
- Quel version de Godot est utilisé ?

Merci d'avance :)
Système d’exploitation : OpenSuSE, FreeBSD
Éditeur de texte : NeoVim

Zatalyz

  • La Papesse
  • Orateur émérite
    • Voir le profil
Re : Lyne Segfault sur Ubuntu 18.04
« Réponse #1 le: 17 février 2022 à 21:12:02 »
Les compte-rendus des réunions hebdomadaires sont la voie d'entrée pour répondre à toutes ces questions et même plus.  :search:

Lyne

  • Cobaye blonde
  • Modérateur Global
  • Orateur émérite
  • *****
    • Voir le profil
Re : Lyne Segfault sur Ubuntu 18.04
« Réponse #2 le: 17 février 2022 à 21:27:20 »
Je parlais du truc que YannK et AleaJactaEst bidouillent avec Godot : https://git.khaganat.net/yannk/godot-third-person-basic-scene
J'ai suivi le tuto / readme (oui, oui, tu vas être content, il y en a un), et j'ai tout bien compris. Même s'il a fallu que j'aille chercher comment lancer un .sh sur internet (et c'est déjà beaucoup pour une blonde). Mais j'ai quand même un segfault au lancement de Godot.

Alea soupçonnait une librairie manquante. A suivre. Et sinon, j'attendrai un vrai client pour tester. Na.

deed

  • Sysadmin
  • Résident du Palais
  • *
    • Voir le profil
Re : Lyne Segfault sur Ubuntu 18.04
« Réponse #3 le: 17 février 2022 à 21:28:42 »
oui, librairies manquantes ou version non compatible

Lyne

  • Cobaye blonde
  • Modérateur Global
  • Orateur émérite
  • *****
    • Voir le profil
Re : Lyne Segfault sur Ubuntu 18.04
« Réponse #4 le: 17 février 2022 à 22:07:07 »
https://github.com/godotengine/godot/issues/57238

Je vais attendre un vrai client. Ou d'avoir le courage de monter Ubuntu de version.
Merci à tous pour les recherches  :-*

Tags: client